Can not install jbilling-community-4.1.1

Kooky's Avatar


26 Oct, 2018 08:34 AM

I downloaded jbilling-community-4.1.1 from the official web site, when I lauched the script:

When I go to the browser, I have: Etat HTTP 404 - /jbilling/signup

I use:

debian_version : 9.5


root@debian-9:~/jbilling/jbilling-community-4.1.1/bin# ./
Using CATALINA_BASE: /root/jbilling/jbilling-community-4.1.1
Using CATALINA_HOME: /root/jbilling/jbilling-community-4.1.1
Using CATALINA_TMPDIR: /root/jbilling/jbilling-community-4.1.1/temp
Using JRE_HOME: /usr/lib/jvm/java-8-openjdk-amd64
Using CLASSPATH: /root/jbilling/jbilling-community-4.1.1/bin/bootstrap.jar:/root/jbilling/jbilling-community-4.1.1/bin/tomcat-juli.jar
Tomcat started.

  1. 1 Posted by ahmed.drira@gma... on 26 Oct, 2018 08:48 AM's Avatar

    Hello could you please show your log file

  2. 2 Posted by vasco on 26 Oct, 2018 09:12 AM

    vasco's Avatar

    I have the same issue, but it is under Ubuntu 16 LTS. The zip archive comes without the DB sql scripts. I tried to install from scripts found over the web and finally I get a DB without errors during creation by scripts. However, the application jbilling is not starting inside Tomcat.
    The zip archive provides a documentation for install that is not working and not consistent with the content of the archive.
    Is there any complete archive and fully working or the solution is to go exclusively to a commercial version ??

  3. 3 Posted by Kooky on 26 Oct, 2018 09:19 AM

    Kooky's Avatar


    Thank you for your prompt reply.

    Attached are the logs

  4. 4 Posted by ahmed.drira@gma... on 26 Oct, 2018 09:44 AM's Avatar

    i think that the issue is because of duplicate c3p0 jars in the web-inf lib.

    Go to your root folder where you have installed jbilling and do a find .
    This would give you two jars

    jbilling-community-4.1.1$ find . -name '*c3p*'

    rename c3p0- to c3p0- and restart the server.
    This should fix the issue.

  5. 5 Posted by Kooky on 26 Oct, 2018 10:03 AM

    Kooky's Avatar

    actually, there were the 2 c3p0 files, I renamed c3p0- but it's still not working

  6. 6 Posted by ahmed.drira@gma... on 26 Oct, 2018 10:07 AM's Avatar

    wich jdk-jre are you using , did you a database

  7. 7 Posted by Kooky on 26 Oct, 2018 10:45 AM

    Kooky's Avatar

    Sorry, renaming the c3p0- file worked, I thought it didn't work because it took a while.
    I just registered, when I try to connect, I get an error:

    Exception while sending notification : Notification not found for sending lost password

    I use the default database for now because I could not fine the db for MySQL, but I will need to use MySQL for production.

    attached the logs file if needed

  8. 8 Posted by ahmed.drira@gma... on 26 Oct, 2018 12:37 PM's Avatar

    forget password features is not working until you configure the plugin whish
    send mail as an admin , you ca configure an smtp server or you have to
    choose the fake send mail plugin which dump the mail in a text file i your
    drive ...

    the for signing in you can pick a user o the database admin for example ad
    on the config file set the password encryption to md5
    , update the password on the DB with an md55 password that you know ...
    string to md5 on google ...

    the you can sign in with admin and the company paracig pony i think ...

  9. 9 Posted by Kooky on 26 Oct, 2018 01:13 PM

    Kooky's Avatar


    I configure my smtp server in file, I can register now, but I don't receive the mail. I have no error in the log file.

    Whe I try to reset the password, The Captcha does not work.

  10. 10 Posted by ahmed.drira@gma... on 26 Oct, 2018 01:21 PM's Avatar

    No it is a captch problem now ,

    The smtp server in the properties file is not for sending email on the
    registration process
    you have to configure a plugin on the admin console ...
    i think that you have to register the captche to work.
    you have to know failling the authentification multiple way will disable
    the user on the database ...

  11. 11 Posted by Kooky on 30 Oct, 2018 10:08 AM

    Kooky's Avatar


    Do you have the complete database for MySQL. I try to use MySQL (mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

    When I launch the url, in the log I have:

    Table 'jbilling.reseller_entityid_map' doesn't exist

    Thanks in advanced!

  12. 12 Posted by ahmed.drira@gma... on 30 Oct, 2018 10:12 AM's Avatar

    Sorry i have used postgresql db ,

  13. 13 Posted by Kooky on 30 Oct, 2018 11:08 AM

    Kooky's Avatar

    Ok thanks!

    One more thing.

    using the default database.

    I settup the smtp server in the file

    In the emails_sent.txt file I saw:

    Date: Fri Oct 26 14:21:56 CEST 2018
    To: my_email
    From: [email blocked]
    Subject: Initial Credentials
    Body: Hello ** ****,

    Welcome to jBilling!.

    Please follow this link to set your credentials:

    I can not understang why the sender is: [email blocked] while i have changed email_from in the properties file.

    After the, is there somewhere else i must change the sender (email_from)?

  14. 14 Posted by ahmed.drira@gma... on 30 Oct, 2018 11:19 AM's Avatar

    Yes , you have to configure it on the plugin section in the administration
    of your company ,
    there is a section for email ,
    the configuration that you have made is note used to send this email, it is
    used to notify when the plugin is not working , it like a failback system

  15. 15 Posted by Kooky on 30 Oct, 2018 11:28 AM

    Kooky's Avatar

    Ok, so, impossible to complete the jbilling configuration.

    I can't receive my password to log in, so I can't configure the administration section.

    Thank you for all!

  16. 16 Posted by vikas bodani on 03 Nov, 2018 04:57 PM

    vikas bodani's Avatar

    Try using the Forgot Password feature on the login screen. That should help
    you login.

    *Vikas Bodani*

  17. 17 Posted by Kooky on 04 Nov, 2018 11:09 AM

    Kooky's Avatar

    Hi Vikas Bodani,

    Thank you.

    When I try to reset the password, I have recaptcha V1 Is shutdown.

  18. 18 Posted by vikas bodani on 05 Nov, 2018 07:27 AM

    vikas bodani's Avatar

    The recaptcha V1 has to be replaced. Use this
    patch for replacement.

    *Vikas Bodani*

  19. 19 Posted by Kooky on 06 Nov, 2018 07:43 PM

    Kooky's Avatar

    Hi Thank you so much, by the way, do you have the database for MySQL connection?

    I can not find tables for MySQL that works, I always have error of missing tables...

  20. 20 Posted by Kooky on 07 Nov, 2018 02:35 PM

    Kooky's Avatar

    Any answer?

  21. 21 Posted by vikas bodani on 07 Nov, 2018 04:46 PM

    vikas bodani's Avatar

    Sure. Allow me sometime to share it with you.

    *Vikas Bodani*

  22. 22 Posted by Kooky on 07 Nov, 2018 05:14 PM

    Kooky's Avatar

    OK, thank you so much.

     I'm using jbilling-community-4.1.1

  23. 23 Posted by vikas bodani on 14 Nov, 2018 09:39 PM

    vikas bodani's Avatar
  24. 24 Posted by vikas bodani on 14 Nov, 2018 09:49 PM

    vikas bodani's Avatar

    Note that the db version is 5.7.24 or higher. It should be < than 5.7.x

    *Vikas Bodani*

  25. 25 Posted by Kooky on 12 Dec, 2018 08:57 AM

    Kooky's Avatar

    Hi Vikas Bodani,

    Unfortunately I still have the captcha problem. and I don't see how to replace the recaptcha V1. Using the this link that you have shared to me.

    patch for replacement.

    I use: jbilling-community-4.1.1

  26. 26 Posted by Kooky on 17 Dec, 2018 10:21 AM

    Kooky's Avatar


  27. 27 Posted by roger.parkinson... on 21 Mar, 2019 02:49 AM

    roger.parkinson35's Avatar


    That turned off recaptcha for me.

  28. 28 Posted by haresimba on 25 Sep, 2020 02:00 PM

    haresimba's Avatar

    I'm having troubles installing jbilling community 4.1.1 its on windows 10 and i'm using postgresql. I'm new to this but i really need to use the plaatform for a billing system, everytime tomcat is run and i try to go to the signup page i get an http 404 error. please assist in how i can solve this

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac